Vijf veelgehooorode misverstanden over WordPress

In dit blog vat ik een aantal hardnekkige misverstanden over WordPress samen die ik vaak hoor. Ik hoor deze misverstanden van allerlei mensen, maar ook van ervaren ontwikkelaars die een uitgesproken hekel aan WordPress hebben.

1. WordPress is onveilig

Een CMS dat bijna 25% van het internet aandrijft is inderdaad kwetsbaar vanwege de grote hoeveelheid schade die potentieel is te behalen door een kwetsbaarheid of lek te vinden. Echter WordPress is de afgelopen jaren steeds veiliger geworden. Daarbij is het niet intrinsiek WordPress zelf dat onveilig is: vaak wordt de onveiligheid door menselijk handelen veroorzaakt: het kiezen van zwakke wachtwoorden, het installeren van onveilige plugins of themes en/of het niet updaten van de WordPress installatie zelf.

2. WordPress is traag

WordPress kan in bepaalde gevallen trager worden, bijvoorbeeld wanneer er extreem veel berichten in de database staan (meer dan 100.000 bijvoorbeeld). WordPress is echter van zichzelf niet traag. Wel kan er een gevoel van traagheid optreden bij bijvoorbeeld supergoedkope webhosting pakketten: deze zijn vaak niet krachtig genoeg om WordPress voldoende snelheid te geven

3. WordPress is niet schaalbaar

Deze hoor ik opvallend vaak, maar is gewoon onwaar. Sterker nog: zonder al te krachtige hardware is WordPress prima in staat duizenden bezoekers per dag af te handelen. Wanneer je er nog veel meer hebt dan kan het geen kwaad om te kijken naar goede caching plugins waarmee je makkelijk tot 1 miljoen bezoekers per dag kunt groeien. Ook zijn er tegenwoordig hele goede alternatieven om betere caching te regelen, zoals bijvoorbeeld CloudFlare of Varnish.

4. Het cms is onhandig

Toegeven, WordPress had lang niet altijd de beste editor, maar dit is grotendeels opgelost in de nieuwe editor Gutenberg. Het is nu heel eenvoudig om artikelen te schrijven, widgets toe te voegen, embeds en quotes te maken. Het CMS is net zo krachtig als dat van grote newsrooms.

5. WordPress zit technisch niet goed in elkaar

Dit is niet waar. WordPress heeft een zeer uitgebreide codex waarin een groot deel van alle functies goed beschreven is. Wel is het zo dat er zaken dubbel zijn, maar dit heeft ook te maken met backward compatibility: beschikbaar blijven voor oudere versies.

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.